Polygon helper fixing

Project:Simile
Version:6.1
Component:Code
Category:bug report
Priority:normal
Assigned:benedetto.rugani
Status:active
Description

Hello,

I have an issue with the Polygon diagram helper, that does not work in version 6. We try using it with Roelof Boumans for MIMES model. He said he had the same issue with version 5 and fixed it, but his correction does not work in 6 anymore. Could you fix it at some point? If yes, do you need I provide you some data or anything else? Don't hesitate. Here is the error message I get:

invalid command name ".mre1.mainpw.mainDisplayPane.notebook.fpage0.panedwindow.pane0.container.bbframe.buttonBox"
invalid command name ".mre1.mainpw.mainDisplayPane.notebook.fpage0.panedwindow.pane0.container.bbframe.buttonBox"
    while executing
"$winId.bbframe.buttonBox index last"
    (procedure "polygon375::initialize" line 18)
    invoked from within
"[KeyValue]::initialize $winId"
    while constructing object "::helper2" in ::similescript::OldStyleHelper::constructor (body line 10)
    invoked from within
"OldStyleHelper::constructor $modelWin $winTitle $state"
    while constructing object "::helper2" in ::similescript::polygon375::constructor (body line 3)
    invoked from within
"similescript::$helperId $inst $modelObj $helperTitle $state"
    (procedure "CreateHelperWindow" line 7)
    invoked from within
"CreateHelperWindow polygon375 {Polygon diagram}"
    (menu invoke)

Sincerely,

Benedetto

 

Comments

#1

Hi, I think we have fixed this in a recent patch to Simile. Please download the version currently on our site and let us know if the problem still exists.

 

#2

Hi Jasper,

Thanks. In fact, it turns out that the polygon helper is not the problem. It is the model that does not compile in 6.1 while it was compiling in 5.9. Can I send you the model (and how) so you can see what goes wrong with compilation?

Thanks in advance.

Benoit

#3

OK, please send the model to support@simulistics.com